Lusha services are unavailable

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Mar 10, 2023 - 12:21 IST

Update

We are continuing to investigate this issue.
Posted Mar 10, 2023 - 12:20 IST

Update

We are continuing to investigate this issue.
Posted Mar 10, 2023 - 12:05 IST

Investigating

We are currently investigating this issue.
Posted Mar 10, 2023 - 11:47 IST
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard, Lusha API, Lusha Website).