Services partial outage

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 15:45 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 15:04 IST

Update

We are continuing to work on a fix for this issue.
Posted Mar 20, 2025 - 14:08 IST

Update

We are continuing to work on a fix for this issue.
Posted Mar 20, 2025 - 14:07 IST

Update

We are continuing to work on a fix for this issue.
Posted Mar 20, 2025 - 13:12 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 12:21 IST
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard, Lusha API, Engage).