Lusha Dashboard Access Issue

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 17:25 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 16:38 IDT

Investigating

We are currently aware of an issue affecting dashboard access for some customers.
Our team is actively investigating and working to resolve it as quickly as possible.
Posted Aug 13, 2025 - 16:06 IDT
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard).