Service Performance Degradation - Under Investigation
Incident Report for Lusha Status Page
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 13:46 IDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 24, 2024 - 13:44 IDT
Investigating
We are currently experiencing reduced performance in some of our services. Our team is actively working to resolve the issue and restore full functionality as quickly as possible.

We apologize for any inconvenience this may cause and will provide further updates as we progress.

Thank you for your understanding and patience.

Sincerely,
The Lusha Team
Posted Sep 24, 2024 - 13:19 IDT
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard).