Cloudflare issues

Incident Report for Lusha Status Page

Resolved

The incident has been resolved, and all services are operating normally. We will continue monitoring to ensure stability.
Posted Dec 05, 2025 - 11:46 IST

Monitoring

Service has been restored following a widespread internet disruption. All systems are operating normally, and we continue to monitor stability.
Posted Dec 05, 2025 - 11:24 IST
This incident affected: Lusha services (Lusha Dashboard).