Lusha.com is not available

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:35 IDT

Monitoring

There’s scheduled maintenance happening with our hosting provider.
Lusha.com will return in about 30 to 50 minutes.
Posted Apr 01, 2025 - 11:32 IDT
This incident affected: Lusha services (Lusha Website).