Login with username/password issue
Incident Report for Lusha Status Page
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 10:33 IST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 13, 2025 - 21:27 IST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2025 - 19:34 IST
Investigating
We are currently investigating this issue.
Posted Jan 13, 2025 - 19:25 IST
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard).