Conversational Intelligence returning 504 errors

Incident Report for Lusha Status Page

Resolved

Conversational Intelligence (EU) is fully restored — the routing issue that caused errors between 07:45–09:05 UTC has been fixed and monitoring is in place to prevent recurrence.
Posted Jun 01, 2026 - 12:46 IDT

Monitoring

Conversational Intelligence (EU) - between 07:45–09:05 UTC users saw errors loading CI features (calendar, meetings, snippets); root cause was an internal routing certificate mismatch, traffic has fully recovered and we are adding monitoring to prevent recurrence.
Posted Jun 01, 2026 - 12:14 IDT

Identified

Conversational Intelligence (EU) - The issue has been identified and a fix is being implemented.
Posted Jun 01, 2026 - 12:09 IDT

Investigating

Conversational Intelligence (EU) - We are currently investigating disruptions to CI service.
Posted Jun 01, 2026 - 11:36 IDT
This incident affected: Lusha services (Engage).