Latency in our services

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Sep 11, 2023 - 11:49 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 11, 2023 - 11:09 IDT

Investigating

We're currently experiencing higher than usual latency in our services.
Our team is actively working to resolve this issue and restore normal performance as soon as possible. We apologize for any inconvenience.
Posted Sep 11, 2023 - 10:43 IDT
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard, Lusha API).