Investigating: Service Disruption in Prospecting

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted May 05, 2026 - 14:07 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 05, 2026 - 13:08 IDT

Investigating

We are currently investigating an issue affecting the availability of our Prospecting service.
You may experience errors or difficulties accessing this feature at this time.
Our engineering team is actively looking into the root cause, and we are working to restore full service as quickly as possible. We apologize for the inconvenience and will provide another update shortly.
Posted May 05, 2026 - 12:59 IDT
This incident affected: Lusha services (Prospecting).