Search Services – Partial Availability

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted May 19, 2025 - 17:28 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 17:25 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 19, 2025 - 17:14 IDT

Investigating

Some search features are currently inaccessible.
Engineering is actively restoring full functionality and progress updates will appear here
Posted May 19, 2025 - 17:09 IDT
This incident affected: Lusha services (PlugIn, Prospecting, Lusha API).