Kinsta Global Outage Affecting Lusha.com

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 23:20 IDT

Update

Kinsta has indicated they have identified the issue.
We are awaiting confirmation as to when service will be restored to the services affecting our integration.
We appreciate your continued patience while this issue is resolved.
Posted Jun 12, 2025 - 22:37 IDT

Identified

Lusha.com is unavailable because of a worldwide outage at our hosting provider, Kinsta.
Our engineering teams are collaborating with Kinsta to restore service swiftly
Posted Jun 12, 2025 - 21:29 IDT
This incident affected: Lusha services (Lusha Website).