Services partial outage

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Feb 07, 2023 - 15:20 IST

Monitoring

Issue has been solved, we continue to investigate and monitor the relevant services.
Posted Feb 07, 2023 - 14:28 IST

Update

We are continuing to investigate this issue.
Posted Feb 07, 2023 - 14:07 IST

Investigating

We are currently investigating this issue.
Posted Feb 07, 2023 - 13:01 IST
This incident affected: Lusha services (PlugIn, Prospecting).