Service Unavailability

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Dec 17, 2024 - 10:35 IST

Update

We are continuing to investigate this issue.
Posted Dec 17, 2024 - 10:34 IST

Update

Lusha is back online. We are sorry for the inconvenience.
Posted Dec 17, 2024 - 09:36 IST

Investigating

We are currently investigating this issue.
Posted Dec 17, 2024 - 08:34 IST
This incident affected: Lusha services (PlugIn, Prospecting, Lusha Dashboard, Lusha API, Lusha Website, Engage).