services outage

Incident Report for Lusha Status Page

Resolved

This incident has been resolved.
Posted Apr 22, 2024 - 10:37 IDT

Update

We are continuing to investigate this issue.
Posted Apr 22, 2024 - 10:16 IDT

Investigating

We are currently investigating this issue.
Posted Apr 22, 2024 - 10:02 IDT
This incident affected: Lusha services (PlugIn, Lusha Dashboard, Lusha API, Engage).